Login problems for Smite PC
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted almost 2 years ago. Sep 25, 2015 - 13:46 EDT
Identified
We will be doing an emergency restart of Smite at 1:27pm EDT
Posted almost 2 years ago. Sep 25, 2015 - 13:07 EDT
Update
We have identified that steam users are having difficulty logging in, and are working to fix the issue
Posted almost 2 years ago. Sep 25, 2015 - 12:36 EDT
Update
We seem to be having issues with steam at the moment
Posted almost 2 years ago. Sep 25, 2015 - 11:20 EDT
Investigating
We are currently investigating this issue.
Posted almost 2 years ago. Sep 25, 2015 - 11:07 EDT