Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Paladins PC issues have been resolved.
Posted 6 months ago. Sep 25, 2016 - 15:40 EDT
Update
We will be taking Paladins offline again for emergency maintenance. #Paladins
Posted 6 months ago. Sep 25, 2016 - 08:29 EDT
Update
We will be taking Paladins offline for emergency maintenance. #Paladins
Posted 6 months ago. Sep 25, 2016 - 06:14 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 6 months ago. Sep 25, 2016 - 05:56 EDT