Tribes Amsterdam Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issues with #TRIBES servers in Amsterdam have been corrected.
Posted 10 months ago. Jun 23, 2016 - 11:45 EDT
Investigating
Currently looking into reported issues with AMS servers for #TRIBES
Posted 10 months ago. Jun 23, 2016 - 11:21 EDT