Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Jan 28, 2017 - 18:33 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted about 2 months ago. Jan 28, 2017 - 18:20 EDT
This incident affected: Smite PS4 - North America / Europe and Paladins PS4.