Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This smite xbox incident has been resolved#smite xbox
Posted over 1 year ago. May 25, 2016 - 22:16 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted over 1 year ago. May 25, 2016 - 21:20 EDT