Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 22, 2017 - 00:55 EDT
Investigating
We will be performing an emergency restart of #Smite on #PC.
We are very sorry for the inconvenience.
Servers will be going offline in 10 minutes.
Posted about 1 month ago. Feb 22, 2017 - 00:27 EDT
This incident affected: Smite PC - North America / Europe.