Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have recovered and will continue to monitor.
Posted 2 months ago. Apr 08, 2018 - 00:53 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 2 months ago. Apr 07, 2018 - 22:50 EDT
This incident affected: Smite (Smite Xbox).