Smite PC Steam Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved#smite
Posted 12 months ago. Mar 29, 2016 - 19:53 EDT
Monitoring
Users might be experiencing issues with steam connectivity at the moment.
#SMITE
Posted 12 months ago. Mar 29, 2016 - 18:09 EDT