Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This SmiteXBOX incident has been resolved. #SmiteXBox
Posted 4 months ago. Mar 18, 2017 - 06:37 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 4 months ago. Mar 18, 2017 - 05:39 EDT