Paladins PS4
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Apr 23, 2017 - 02:24 EDT
Monitoring
Restart of #Paladins on #PS4 has been completed.
We are continuing to monitor the environment.
Posted Apr 23, 2017 - 02:23 EDT
Investigating
We are performing an emergency restart on #Paladins for #PS4.
We apologize for the inconvenience.
Posted Apr 23, 2017 - 02:15 EDT
This incident affected: Paladins (Paladins PS4).