Smite PC Emergency Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Restart has been completed and logins resuming.
Posted about 1 month ago. Aug 10, 2017 - 14:17 EDT
Identified
We are having to perform a #Smite #PC Emergency Restart
Posted about 1 month ago. Aug 10, 2017 - 14:04 EDT
This incident affected: Smite PC - North America / Europe.