Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue with #Paladins #PC has been resolved.
Posted Sep 21, 2017 - 20:17 EDT
Monitoring
Logins for #Paladins #PC have been resumed. We are monitoring the results.
Posted Sep 21, 2017 - 19:42 EDT
Update
Logins for #Paladins #PC have been temporarily limited to investigate an issue.
Posted Sep 21, 2017 - 19:19 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Sep 21, 2017 - 19:10 EDT
This incident affected: Paladins (Paladins PC).