XBOX Live Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted over 2 years ago. Jul 14, 2015 - 23:05 EDT
Identified
Xbox Live is having issues currently.... to log into Smite, just skip past the sync player data #smite
Posted over 2 years ago. Jul 14, 2015 - 21:59 EDT