Smite PS4 Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Psn network seems to be fixed#smite
Posted 9 months ago. Sep 06, 2016 - 22:54 EDT
Update
Posted 9 months ago. Sep 06, 2016 - 20:43 EDT
Identified
PSN network is currently having issues with account management
https://status.playstation.com/en-US/
http://downdetector.com/status/playstation-network#smite
Posted 9 months ago. Sep 06, 2016 - 17:34 EDT
Investigating
Automated services have detected a possible problem with #SMITE PS4. We are investigating.
Posted 9 months ago. Sep 06, 2016 - 17:31 EDT