Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Issue is resolved with Hirez Games; #SMITE #Paladins #Tribes
Posted 3 months ago. Feb 02, 2017 - 18:10 EST
Monitoring
We are currently monitoring Hirez Games at this time.
Posted 3 months ago. Feb 02, 2017 - 17:57 EST
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 3 months ago. Feb 02, 2017 - 17:47 EST
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, Paladins Xbox, and Paladins PS4.