Smite PS4 and Paladins XBox experiencing issues
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite #PS4 and #Paladins #XBox have recovered.
Posted 7 days ago. May 19, 2017 - 01:38 EDT
Monitoring
We have mitigated issues with #Smite #PS4 and #Paladins #XBox and are continuing to monitor.
Posted 7 days ago. May 19, 2017 - 01:12 EDT
Identified
We have identified the issue with #Smite #PS4 and #Paladins #XBox and are working to mitigate.
Posted 7 days ago. May 19, 2017 - 00:59 EDT
Investigating
#Smite #PS4 and #Paladins #XBox experiencing issues. We are currently investigating.
Posted 7 days ago. May 19, 2017 - 00:22 EDT
This incident affected: Smite PS4 - North America / Europe and Paladins Xbox.