Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved and we are continuing to monitor #SmitePC
Posted about 2 months ago. May 06, 2017 - 14:08 EDT
Monitoring
A fix has been implemented and we are monitoring the results. #SmitePC
Posted about 2 months ago. May 06, 2017 - 13:39 EDT
Update
We are currently investigating this issue #SmitePC
Posted about 2 months ago. May 06, 2017 - 13:11 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 2 months ago. May 06, 2017 - 13:03 EDT