Smite PC Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
These Issues have been resolved.
#Smite
Posted 10 months ago. Jun 07, 2016 - 13:35 EDT
Identified
We have Identified the Issue and are working to remedy the problem.
Thank you for your continued patience.
#SMITE
Posted 10 months ago. Jun 07, 2016 - 12:24 EDT
Investigating
We are aware of the issues effecting players loading into matches on #Smite-PC
We are currently Investigating, sorry for the inconvenience.
Posted 10 months ago. Jun 07, 2016 - 11:03 EDT