Paladins PC Ranked Matches Disabled
Incident Report for Hi-Rez Studios, Inc
Resolved
Ranked matches have been enabled for #Paladins #PC
Posted 3 months ago. Jul 26, 2017 - 18:07 EDT
Investigating
#Paladins PC Ranked Matches will be temporarily disabled while we investigate performance issues.
Posted 3 months ago. Jul 26, 2017 - 15:06 EDT
This incident affected: Paladins PC.