Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite #PC has recovered; this issue has been resolved.
Posted 3 months ago. Feb 07, 2017 - 21:39 EST
Monitoring
We have corrected an issue with #Smite #PC; logins are enabled; continuing to monitor.
Posted 3 months ago. Feb 07, 2017 - 21:27 EST
Identified
We have identified an issue with #Smite #PC; logins temporarily limited; game back shortly.
Posted 3 months ago. Feb 07, 2017 - 21:15 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 3 months ago. Feb 07, 2017 - 21:13 EST
This incident affected: Smite PC - North America / Europe.