Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #Smite PC
Posted about 1 month ago. Mar 26, 2017 - 22:34 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 month ago. Mar 26, 2017 - 21:27 EDT