Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue has been resolved.
Posted 23 days ago. Nov 19, 2017 - 16:31 EST
Monitoring
Restart has been completed, continuing to monitor.
Posted 23 days ago. Nov 19, 2017 - 15:55 EST
Update
We are performing and emergency restart on #Smite #Xbox
Posted 23 days ago. Nov 19, 2017 - 15:40 EST
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted 23 days ago. Nov 19, 2017 - 15:34 EST
This incident affected: Smite Xbox - North America / Europe.