Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Jun 28, 2017 - 10:52 EDT
Monitoring
Emergency restart of #Smite #XBox has been completed. We will continue to monitor.
Posted Jun 28, 2017 - 10:39 EDT
Identified
We will be performing an emergency restart of #Smite #Xbox
Posted Jun 28, 2017 - 10:22 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted Jun 28, 2017 - 10:16 EDT