Smite PS4 Login issues
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PS4 incident has been resolved.#smite
Posted 6 months ago. Dec 12, 2016 - 12:07 EST
Investigating
PSN is currently undergoing some maintenance, so Smite PS4 users may have issues logging in#smite
Posted 6 months ago. Dec 12, 2016 - 11:42 EST