Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
We have identified the issues preventing logins in #Smite on #PC.
Logins have resumed and we are continuing to monitor the environment.
Posted 6 days ago. Mar 20, 2017 - 19:45 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 6 days ago. Mar 20, 2017 - 19:36 EDT
This incident affected: Smite PC - North America / Europe.