Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Have been experiencing intermittent data center connectivity issues that momentarily impacted #SMITE PC and XBox and #PALADINS PC. We are recovering.
Posted about 1 year ago. Feb 23, 2016 - 15:07 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Feb 23, 2016 - 14:55 EST