Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted Sep 21, 2017 - 09:46 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 21, 2017 - 09:38 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted Sep 21, 2017 - 09:36 EDT