Smite-Console Logins Paused
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 month ago. Feb 13, 2017 - 08:32 EDT
Investigating
We will be pausing logins momentarily for #Smite on #Xbox and #PS4
Posted about 1 month ago. Feb 13, 2017 - 08:18 EDT
This incident affected: Smite Xbox - North America / Europe and Smite PS4 - North America / Europe.