Currently can not launch instances on Smite XBOX
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 years ago. Nov 06, 2015 - 13:28 EST
Identified
The issue has been identified and a fix is being implemented.
Posted about 2 years ago. Nov 06, 2015 - 13:28 EST
Investigating
Investigating
Posted about 2 years ago. Nov 06, 2015 - 13:09 EST