Issues with in-game Store
Incident Report for Hi-Rez Studios, Inc
Resolved
This issue is resolved; closing incident.
Posted 9 months ago. Aug 10, 2016 - 04:17 EDT
Monitoring
#Smite PC and #Paladins PC store issues should be resolved; continuing to monitor
Posted 9 months ago. Aug 10, 2016 - 01:21 EDT
Update
Still intermittent issues with the #Smite PC and #Paladins PC store, we are continuing to troubleshoot.
Posted 9 months ago. Aug 09, 2016 - 22:14 EDT
Identified
believe we have Identified issue with #Smite PC and #Paladins PC store; still working to resolve.
Posted 9 months ago. Aug 09, 2016 - 19:17 EDT
Investigating
#Smite PC and #Paladins PC in-game stores are having issues; we are working to resolve
Posted 9 months ago. Aug 09, 2016 - 17:59 EDT