We we be limiting logins for a few moments to restart a service on Paladins PC
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved. #PaladinsPC
Posted 5 months ago. Mar 29, 2017 - 10:36 EDT
Investigating
We we be limiting logins for a few moments to restart a service on Paladins PC # PaladinsPC
Posted 5 months ago. Mar 29, 2017 - 10:32 EDT
This incident affected: Paladins PC.