Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Dec 23, 2016 - 15:11 EST
Identified
Steam Service is currently experiencing issues. We are monitoring. #SMITE
Posted 4 months ago. Dec 23, 2016 - 10:51 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Dec 23, 2016 - 10:50 EST
This incident affected: Smite PC - North America / Europe.