Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
The issues with Smite PC have been resolved. #SMITE #PC
Posted 8 months ago. Mar 11, 2017 - 18:02 EST
Monitoring
We are monitoring Smite PC at this time. #SMITE #PC
Posted 8 months ago. Mar 11, 2017 - 17:40 EST
Identified
We are currently looking at issues with Smite PC. #SMITE #PC
Posted 8 months ago. Mar 11, 2017 - 17:33 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 8 months ago. Mar 11, 2017 - 17:19 EST
This incident affected: Smite PC - North America / Europe.