Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins PC incident has been resolved#paladins
Posted over 1 year ago. Aug 20, 2016 - 12:23 EDT
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted over 1 year ago. Aug 20, 2016 - 12:00 EDT