Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
#Smite PC is functioning normally again
Posted about 1 year ago. Mar 03, 2016 - 09:21 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 year ago. Mar 03, 2016 - 08:16 EDT