Issue with logging into HiRez Products
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 10 months ago. Nov 22, 2016 - 23:43 EST
Monitoring
We have identified the issue and are currently monitoring the situation.
Posted 10 months ago. Nov 22, 2016 - 23:37 EST
Investigating
We are currently looking into issues with logging into HiRez Products. #SMITE #PALADINS.
Posted 10 months ago. Nov 22, 2016 - 22:21 EST