Hi-Rez Game Issues
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 2 months ago. Feb 03, 2017 - 21:20 EDT
Investigating
We are currently working to resolve issues involving matches and match making with some of our environments.
We apologize for the inconvenience.
Posted about 2 months ago. Feb 03, 2017 - 20:59 EDT
This incident affected: Smite PC - North America / Europe, Smite Xbox - North America / Europe, Smite PS4 - North America / Europe, Paladins PC, and Paladins Xbox.