Paladins PC Login problems
Incident Report for Hi-Rez Studios, Inc
Resolved
The issue affecting #Paladins #PC Logins has been resolved and we are continuing to monitor.
Posted 15 days ago. Jun 09, 2018 - 14:25 EDT
Investigating
We are investigating the login issues effecting #Paladins #PC
Posted 15 days ago. Jun 09, 2018 - 13:36 EDT
This incident affected: Paladins (Paladins PC).