Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved. #Paladins #PC
Posted about 2 months ago. Mar 05, 2017 - 02:47 EST
Identified
We will be pausing logins temporarily in #Paladins #PC
Posted about 2 months ago. Mar 05, 2017 - 02:32 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted about 2 months ago. Mar 05, 2017 - 02:28 EST
This incident affected: Paladins PC.