Stopping Smite XBOX logins for a short amount of time
Incident Report for Hi-Rez Studios, Inc
Resolved
Smite-XBox logins have resumed normally.
#SMITE
Posted about 1 year ago. Mar 02, 2016 - 11:03 EST
Investigating
Smite XBox Live will have it's logins halted for a short amount of time.
Sorry for the inconvenience.
#SMITE
Posted about 1 year ago. Mar 02, 2016 - 10:54 EST