Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #SmitePC
Posted about 1 month ago. Apr 17, 2017 - 22:06 EDT
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted about 1 month ago. Apr 17, 2017 - 21:56 EDT
This incident affected: Smite PC - North America / Europe.