Xbox Live Reporting Purchase and Content Usage Outage
Incident Report for Hi-Rez Studios, Inc
Resolved
Xbox Live is reporting this issue as resolved. https://bit.ly/1wTAWYd
Posted 2 months ago. May 15, 2018 - 16:15 EDT
Monitoring
Xbox Live is reporting issues with purchase and content usage which may affect #Smite, #Paladins, and #HotG purchases as well as founder's/champions/god pack usage on #Xbox. For further information: https://bit.ly/1wTAWYd
Posted 2 months ago. May 15, 2018 - 14:05 EDT
This incident affected: Paladins (Paladins Xbox), Hand of the Gods (Hand of the Gods Xbox), and Smite (Smite Xbox).