Smite XBOX Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted about 1 year ago. Mar 30, 2016 - 10:28 EDT
Monitoring
Xbox live is still currently having issues
http://support.xbox.com/en-US/xbox-live-status?icid=furl_status #smite
Posted about 1 year ago. Mar 30, 2016 - 02:09 EDT
Identified
Smite Xbox users may experience issues with In-game matchmaking, cloud storage, finding friends.
Xbox Live is currently having issues
http://support.xbox.com/en-US/xbox-live-status?icid=furl_status
#smite
Posted about 1 year ago. Mar 29, 2016 - 22:26 EDT
Investigating
Automated services have detected a possible problem with #SMITE XBOX. We are investigating.
Posted about 1 year ago. Mar 29, 2016 - 22:20 EDT