Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Smite PC incident has been resolved. #SmitePC
Posted 6 months ago. Feb 04, 2017 - 20:15 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 6 months ago. Feb 04, 2017 - 20:03 EST
This incident affected: Smite PC - North America / Europe.