Paladins PC performance issues
Incident Report for Hi-Rez Studios, Inc
Resolved
#Paladins PC is back up
Posted 9 months ago. Sep 18, 2016 - 13:25 EDT
Investigating
#Paladins PC is down, should be back by 1:30pm
Posted 9 months ago. Sep 18, 2016 - 13:12 EDT