Paladins PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
Emergency Restart of #Paladins #PC has concluded.
Posted 12 days ago. Feb 10, 2018 - 18:06 EST
Investigating
Automated services have detected a possible problem with #Paladins PC. We are investigating.
Posted 12 days ago. Feb 10, 2018 - 17:49 EST
This incident affected: Paladins PC.