Pausing Logins on Smite-Xbox
Incident Report for Hi-Rez Studios, Inc
Resolved
Logins have resumed to normal for #Smite on #XBOX.
Posted 8 months ago. Sep 08, 2016 - 21:14 EDT
Investigating
We will be pausing logins for a short amount of time on #Smite for #Xbox.
We apologize for the inconvenience.
Posted 8 months ago. Sep 08, 2016 - 20:46 EDT