Paladins Restart
Incident Report for Hi-Rez Studios, Inc
Resolved
Resolved: This Paladins incident has been resolved.#paladins
Posted 9 months ago. Oct 15, 2016 - 12:01 EDT
Investigating
We are going to do a quick restart on Paladins, sorry for the inconvienance .#paladins
Posted 9 months ago. Oct 15, 2016 - 11:20 EDT