Smite PC Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 03, 2017 - 20:33 EST
Identified
We will be performing an emergency restart on #Smite #PC
Posted 4 months ago. Feb 03, 2017 - 19:54 EST
Investigating
Automated services have detected a possible problem with #SMITE PC. We are investigating.
Posted 4 months ago. Feb 03, 2017 - 19:48 EST
This incident affected: Smite PC - North America / Europe.