Hirez Games Possible Issue
Incident Report for Hi-Rez Studios, Inc
Resolved
This incident has been resolved.
Posted 8 months ago. Feb 01, 2017 - 16:15 EST
Investigating
Automated services have detected a possible data center issue that may impact all games. We are investigating. #SMITE #Paladins #Tribes
Posted 8 months ago. Feb 01, 2017 - 15:44 EST